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Advanced Process Controller
Introduction

 
 
Introduction

 
Advanced Process Controller allows you to view all processes currently running on 
your system  and to manage them. You are able to kill selected processes in a snap, 
which can not be realized by the classic Task Manager. It is an extremely powerful and 
versatile replacement for the Windows Task Manager. This impressive utility is an 
absolute power user's delight. Advanced Process Controller provides an attractive tabbed 
interface that shows active processes, finished processes, windows, modules, and a 
statistics panel that features real-time monitoring for memory and CPU usage. You can 
kill selected processes,  and easily retrieve information regarding process/module 
dependencies. 

Advanced Process Controller is an easy-to-use program designed to help you to 
manage all of your jobs and tasks. Easy data entry allows for minimal time spent on 
logging new and editing existing tasks.
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Advanced Process Controller
Features

Features Overview 
 

What the Advanced Process Controller is and what you can do with it: 
 

●     you can easily see what's happening behind the desktop. 

●     you can see the modules of each running process, Advanced Process Controller 
lets you close normally or kill any running process.

●     see graphs and data on CPU and memory usage.

●     complete information about processes and modules.

●     click the process show the general information. 

●     specify process counter column headings. 

●     blacklist which confirms that items being analyzed are not acceptable. 

●     whitelist which confirms that the item being analyzed is acceptable.

●     free online resource for process information through Google. 

●     pause process suspends the execution of process until it is reactivated by the 
resume process command. 

 
 
 
 
So, with one quick look you can see that Advanced Process Controller is the tool 
you're looking for a long time, it shows you the backstage of your computer, and 
more, it lets you control things. 
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Advanced Process Controller
The user interface (Overview)

The user interface (Overview) 

 
 

 
 
 
 

Overview: When Advanced Process Controller is started, all currently running processes 
are displayed in the Processes tab page. 
 
Toolbar: Including features of adding new applications, regulating upgrade speed , 
selecting columns for processes and help content, which allow users to run these relevant 
commands conveniently .  
 
Task Panel: Allow users to approve or deny some of the commonly used tasks.

Tab Page: Including tabs of Application, Processes, Performance, Blacklist, and Whitelist. 
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To navigate from one page to the other, you need to click on those tabs.
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Advanced Process Controller
Using Process of Toolbar

How to Add a new application

You are able to add a new application by clicking  

 
The following steps describe how to add a new application 
 

Step1: Click the the button "New Application" to open the Windows Run dialog. 
 

Step2: Type the name of a program, folder, document or internet resource, and 
windows will open it for you. in  

 

About Update Speed

This function allows you to choose the frequency at which the data is automatically 

updated, Click menu, then point to the command you want. To 

temporarily freeze the data displayed in Advanced Process Controller, Click "Paused" 
in the same menu. Data is automatically updated every one second by default.

How to select columns

The following steps describe how to select columns: 
 

Step1:Click the button "process" on the tab page. 
 

Step2:Cick the button , and then it appears a following dialog:  
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Select the columns that you are about to add on the process page of the process 
manager, click OK to finish your order or Cancel it. 

How to Use Help Content

 

Right click to hide or show the toolbar, and you can customize the menu bar and 
toolbar at your will: 
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Other Using Process:

Using Process of Application

Using Processes

Using Process of Performance

Using Process of Blacklist

Using Process of Whitelist
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Advanced Process Controller
Using Process of Applications

Using Process of Applications

Step 1: Click "Applications" on Tab Page, Advanced Process Controller displays all 
active programs on the taskbar. 

 

Step 2: If you wish more tasks on a program, you can select it in the list and then click 
the task you need on the Task Panel.  
Or select it in the list and then right click the task you need.  
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To switch to another program 
On the Applications tab, click the program you want to switch to, and then click Switch To

To bring a program to front 
On the Applications tab, click the program that you want to bring to front, and then click 
Bring To Front.

To control the program's window 
On the Applications tab, you are able to minimize or maximize the operation window of 
the selected program. 

 
To end a program with Advanced Process Controller 

On the Applications tab, click the program that you want to end, and then click the "End 
Task" button. 

WARNING: Any data entered or changes made in that program and not saved will be 
lost.
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 To go to the process interface  

On the Applications tab, you can switch to the process interface and view the process 
information of selected program by clicking Go To Process. . 

 
Other Using Process:

Using Process of Toolbar

Using Processes 

Using Process of Performance

Using Process of Blacklist

Using Process of Whitelist
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Advanced Process Controller
Using Processes

Using Processes

 
 
Advanced Process Controller allows you to view detailed processes information (with 
descriptions), stop and start new processes, set priorities and much more. You can easily 
find and remove unnecessary background processes.

You can easily see what's happening behind the desktop which processes are running on 
your computer. 

On the Processes interface, left click a listed process, you are able to view the General 
information about the process, or to hide this displayed information by clicking Show Tips 
under the View menu. The following steps will assist to view the detailed information of 
listed process.  
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Step 1 

Advanced Process Controller allows you to end process, right click the process you want 
to end, then point to the "end process". 

WARNING: Terminating a process can cause undesired results including loss of data 
and system instability. The process will not be given the chance to save its state or data 
before it is terminated. 

Step 2

A. To debug the selected program by clicking the "Debug". 

WARNING: This operation may result in loss of data.

B. Pause process suspends the execution of process until it is reactivated by the resume 
process command, click the "pause" or "resume". 

WARNING: This operation will attempt to pause this process. If you pause some 
system process, it can cause system instability

C. Resume the paused process by clicking "Resume".
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D. Delete the process by clicking the "Delete Process". 

WARNING: Delete a process can cause undesired results including loss of data and 
system instability. It will delete the execute file of this process. 

Step 3:  
 
Click " Show Details" to show information, used modules and used threads about the 
process. (Same operation available in the Action area) 
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A: To unload module of a process. 
On the Modules Used tab, click the module that you want to unload, and then right-click 
to Unload Module  
 
B: To delete module of a process 
On the Modules Used tab, click the module that you want to delete, and then right-click 
to Delete Module. 
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WARNING: The two operations may cause the process crash and if you unload or 
delete module of some system process, it can cause system instability.

C: To open properties of a process module. 
Click Open Properties, it will display the properties of the selected module. 
D: To open folder for a process module. 
Click Open Folder to open the folder of selected module. 

E: Free online resource for module information through Google, by clicking "Google 
Module".

Note: You are able to search the online resource, open properties and folder for the 
selected process in the Action part. 
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Step 4: You can end or Pause thread suspends the execution of process until it is 
reactivated by the resume thread command, like this dialog: 

WARNING: This operation will attempt to end the thread of this process, it may cause 
the process break down and instability. 

 

Other Using Process: 

Using Process of Toolbar

Using Process of Application

Using Process of Performance

Using Process of Blacklist

Using Process of Whitelist
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Advanced Process Controller
Using Process of Performance

Using Process of Performance

Memory and CPU performance data displays on this page, including physical and virtual 
memory, and CPU usage. The data refreshes at the same interval that the main display 
does. The Performance tab provides detailed information on the current status of your 
system. You can view the current processor usage in percent, and a graph of the 
processor usage for the last several seconds. A similar graph also shows memory usage 
for the last several seconds. You can also view the current usage of the paging file and 
the physical memory on kilobytes.  
 

Click "Performance" on the Tab Page, the performance graph displays memory and CPU 
performance data, including physical and virtual memory and CPU usage. 
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Other Using Process:

Using Process of Toolbar

Using Process of Application

Using Processes

Using Process of Blacklist

Using Process of Whitelist
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Advanced Process Controller
Using Process of BlackList

Using Process of BlackList

Advanced Process Controller offers feature of "Black List" (the list of processes that will 
be terminated in your system). Blacklist will terminate unwanted or badly-behaved 
processes immediately if the process name matches anyone on your list . If you want to 
terminate processes, add unwanted processes to Blacklist. Then Blacklist will terminate 
all listed processes immediately. 
The following steps describe how to kill processes on Blacklist. 
 

Step 1: Click "Blacklist" on Tab page. 
Step 2: Type the name of the process that you want to add to the list, then click 

 or "Add To List" in the Actions part.  

Step 3: Click "Delete From List" to delete the selected program from the blacklist.

Step 4: Click "Auto Kill" to terminate all processes listed in the Blacklist.
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Warning: This operation will attempt to terminate listed processes. The process will 
not be given the chance to save its state or data before it is terminated. Be circumspect 
when kill listed processes.

 
Other Using Process:

Using Process of Toolbar

Using Process of Application

Using Processes

Using Process of Performance

Using Process of Whitelist
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Advanced Process Controller
Using Process of White List

Using Process of WhiteList

White List which confirms that the item being analyzed is acceptable, it is a list of process 
names from which the process will be allowed to run. 

You can add allowed or safe processes in whitelist , Advanced Process Controller will 
terminate all unlisted processes when you click Autokill. 

step 1: Type in the process name you want to add ,then click  or the "Add To 

List".

step 2: If you want to remove a process from the list, click "Delete From List".

step 3:Click "Auto Kill" Advanced Process Controller allows users to terminate all 
unlisted processes. page 26



Warning: This operation will attempt to terminate all unlisted processes. The unlisted 
process will not be given the chance to save its state or data after you click "Auto kill"

 
Other Using Process:

Using Process of Toolbar

Using Process of Application

Using Processes

Using Process of Performance

Using Process of Blacklist
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Advanced Process Controller
Question Icon

Question Icon

The button  shows other information about Advanced Process Controller. 
Clicking this icon, you will see the bellowing window: 

 
Help Content: Click this button or the Key "F1"(it works anywhere in the program), 
and a detailed help page about Advanced Process Controller will open. .  
Registry :Guide to the  registration window.  
Enter Key: Enter the registration key to switch the trial version into full version.  
Online Resources: Link to WindowsSupporter Website .  
Contact Technical Support: Contact our Support Team.  
About: Show the information of this software.  
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Advanced Process Controller
About WindowsSupporter

About WindowsSupporter

Be the Global Leader of Windows!  
 
 
Being a shareware developer of Windows Operating System solutions, 
WindowsSupporter take the lead in this domain. We have professional experience in 
execute our faith - Think as A Customer. This gives us the idea to create reliable 
and simple-in-use software products for you.  
 
WindowsSupporter R&D Center creates simple solutions to complicated problems. 
And sleek, clear interfaces in our accomplishment make everything you need from 
us being enjoyable. 
 
Contact Us 
 
For Customers 
Email: 
English: support@windowssupporter.com 
French: support_fr@windowssupporter.com 
German: support_de@windowssupporter.com 
Tel:  
+1 952 646-5022 (for calls from outside the U.S.)  
+1,800,406 4966 (for calls from inside the U.S.) 
Advanced Process Controller 
Product ID: 300171544 

 
We always do our best to answer your question! 
 
For Partners 
North America: 
sales@windowssupporter.com 
We benefit together with our partners in a win-win model - the WindowsSupporter 
Business Model, and we love to talk about our creations with you. 
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Advanced Process Controller
FAQs

FAQs

Replacing Task Manager  
 
If you click File > Replace Task Manager, Advanced Process Controller integrates 
itself into your system so that you can access the module by pressing Ctrl+Alt+Del, 
or by right clicking on an empty part of the taskbar and selecting Task Manager. If 
you want to use the Windows Task Manager again, simply select the same menu 
item to remove the check mark in front of it. 
Note: This function is only available for Windows 2000 and Windows XP.  
 

Menu bar functions 
 
The menu bar at the top of the Advanced Process Controller window provides you 
with additional functions.  
 
Click File > New Application (Run...) to open the Windows Run dialog, which you can 
use to start a new application or open a file.  

Click Option > Select Columns ,On this page you can specify which columns 
(information) you want to see in the list view of Process Info. 

Click View > Always On Top, the process you choose always display on the most 
preceding.

Click Shut Down > Turn off, you can close your computer or restart it.

Click Help > Help content , show more help information in using of Advanced Process 
Controller. 
 

To end a process  
 
Click the process that you want to end, and then click End Process. 

 Be careful when ending a process. If you end an application, you will lose 
unsaved data. If you end a system service, some part of the system might not 
function properly. 

 Process Properties

The "Process Properties" dialog displays additional information about a process.

The following info is shown:

A: Complete version resource page 31



B: Path of the process executable 

C: Current working directory 

D: Environment variables

E: Resource types 

F: Common file information
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Advanced Process Controller
How to buy Advanced Process Controller

How to buy Advanced Process Controller

As soon as you make your order, our resellers will verify it. Your order will most 
likely be processed within less than 1 hour, but in some VERY rare cases it may 
take resellers more than 24 hours to process your payment.  
 
The registration key will be automatically generated at our server and e-mailed to 
you immediately after we receive payment confirmation from our e-commerce 
reseller.  
 
Please do not worry if you haven't received the registration information right 
away. Delays usually occur due to the high security settings of spam filters used by 
our clients. Our message may be rejected as a spam message by the mail service 
you use.  
 
If you haven't got the registration message in several hours, feel free to contact 
our Support Teamvia email.  
 
If you have questions concerning our software, please send e-mail to: 
support@windowssupporter.com. We always do our best to help you!

Why Advanced Process Controller?

Save Time 
a. It is outstanding in high-speed; 
b. The easy-in-use interface reduces your time in learning; 
 

 
Save Money

a. It is one-way ticket you have to buy in fixing all your registry 
problems; 
b. Guarantee 30-days-money-back if you are unsatisfied with it! 

 
All in one tool 

Do more with dealing with badly-behaved programs, show more details 
about the process and kill programs manually are all supported by this 
powerful tool. 

 
Easy-in-use 

It is easy to use and fast in speed, With step-by-step manual, Whether you 
page 33

mailto:support@windowssupporter.com
mailto:support@windowssupporter.com
https://secure.element5.com/shareit/checkout.html?productid=300171544

&language=English


are an experienced user or a beginner, the software will make the task of 
optimizing your system a breeze! 

 

What will you have after purchase?

Full version of Advanced Process Controller 
There would no limit in its functions, and you could have fun in unlimited 
system optimizing. 

 
Lifetime license  

When you purchase Advanced Process Controller, you get free online 
upgrades on the main version with Lifetime Upgrade Policy. 

 
Customer care 

We are pleased to offer our care to meet your needs. We promise that any 
customer question will be satisfied within 1 business day! 

 
Coupons for WindowsSupporter products in Discount Center 

We prepared a series of benefits for our customers.
 

Is my order secure?

We promise the most secure purchase as we did for years. 
ShareIt and RegNow, all these WindowsSupporter partners passed strict 
certification. We truly believe in 'Only by benefiting our customer can we benefit 
ourselves'. So your purchase security in WindowsSupporter is one of the top affairs 
we care about! WindowsSupporter has been involved in E-commerce for years. And 
through these years, we built up a secure online shopping system. You can enjoy 
the high-speed and convenience we offered. 
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